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Preface

The Network Configuration Manager* (NCM) application offers a solution for one of the 
most problematic areas of networking — configuration management. By taking advantage 
of the unique capabilities of the Java* programming language, NCM provides 
comprehensive, platform-independent management capabilities that revolutionize the 
approach to configuring networks. 

This guide is part of the NCM documentation set, and describes how to install the NCM 
for BCM3.7 cartridgeNCM. 

Before you begin
This guide is intended for the network administrator who is responsible for administering 
the NCM server (the NCM administrator). The NCM administrator also should have 
experience in the following knowledge:

• Working knowledge of the Windows∗ operating system or Solaris* windowing 
systems and graphical user interfaces (GUIs) 

• Familiarity with basic networking terminology, theories, and practices 

Symbols used in this guide
This guide uses these symbols to draw your attention to important information:

Note: The complete NCM documentation set is located on the 
documentation CD that is included in the NCM3.6 package. 

Note: Note/Tip symbol
Alerts you to important information.
Release Notes and Cartridge Installation Guide for BCM3.7



8 Preface
Text conventions
This guide uses the following text conventions:

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the 
brackets when entering the command.
Example: If the command syntax is
ping <ip_address>, you enter
ping 192.32.10.12

bold Courier text Indicates command names, options, and text that you 
must to enter.
Example: Use the dinfo command. 
Example: Enter show ip {alerts|routes}.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do 
not type the brackets when entering the command.
Example: If the command syntax is
show ip interfaces [-alerts], you can enter 
either show ip interfaces or 
show ip interfaces -alerts.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two 
or more words, the words are connected by an 
underscore.
Example: If the command syntax is
show at <valid_route>, valid_route is one 
variable and you substitute one value for it.

plain Courier 
text

Indicates command syntax and system output, such as, 
prompts and system messages.
Example: Set Trap Monitor Filters

separator ( > ) Shows menu paths. 
Example: Protocols > IP identifies the IP option on the 
Protocols menu. 
N0033985 1.0
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Acronyms
This guide uses the following acronyms:

Related publications
For more information about using NCM, refer to the following publications: 

• Network Configuration 3.6 Release Notes
• Network Configuration Manager 3.6 Installation Guide
• Network Configuration Manager 3.6 Administration Guide
• Network Configuration Manager 3.6 Client Software User Guide
Another useful reference is the Business Communications Manager 3.7 Programming 
Operations Guide.

BCM Business Communications Manager

CR Change Request

DLCI Data Link Connection Identifier

IPSec IP Security Protocol

ISDN Integrated Services Digital Network

IVR Interactive Voice Response

NCM Network Configuration Manager

NIC Network Interface Card

PPTP Point-to-Point Tunnel Protocol

SNMP Simple Network Management Protocol

SRG Survivable Remote Gateway

TFTP Trivial File Transfer Protocol
Release Notes and Cartridge Installation Guide for BCM3.7
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How to get help

Technical Support Contact Numbers 
If you do not see an appropriate number in this list, go to www.nortel.com/cs

• USA and Canada Authorized Distributors 
Technical Support - GNTS/GNPS 
Telephone: 1-800-4NORTEL (1-800-466-7835) 

If you already have a PIN Code, you can enter Express Routing Code (ERC) 
196#. 
If you do not yet have a PIN Code, or for general questions and first line support, 
you can enter ERC 338#. 
Website: www.nortel.com/cs
Presales Support (CSAN) 
Telephone: 1-800-4NORTEL (1-800-466-7835) 
Use Express Routing Code (ERC) 1063#. 

• EMEA (Europe, Middle East, Africa) 
Technical Support - CTAS 
Telephone: *European Free phone 00800 800 89009 

European Alternative/ 
United Kingdom +44 (0)870-907-9009 
Africa +27-11-808-4000 
Israel 800-945-9779 
*Note: Calls are not free from all countries in Europe, Middle East, or Africa. 
Fax: 44-191-555-7980
email: emeahelp@nortelnetworks.com 

• CALA (Caribbean & Latin America) 
Technical Support - CTAS 
Telephone: 1-954-858-7777 
email: csrmgmt@nortelnetworks.com 

• APAC (Asia Pacific) 
Technical Support - GNTS 
Telephone: +612 8870 8800 
Fax: +612 8870 5569 
email: asia_support@nortelnetworks.com 
N0033985 1.0
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• In-country toll-free numbers:
Australia 1-800-NORTEL (1-800-667-835) 
China 010-6510-7770 
India 011-5154-2210 
Indonesia 0018-036-1004 
Japan 0120-332-533 
Malaysia 1800-805-380 
New Zealand 0800-449-716 
Philippines 1800-1611-0063 
Singapore 800-616-2004 
South Korea 0079-8611-2001 
Taiwan 0800-810-500 
Thailand 001-800-611-3007 
Service Business Centre & Pre-Sales Help Desk +61-2-8870-5511 
Release Notes and Cartridge Installation Guide for BCM3.7
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Chapter 1
Introduction

Network Configuration Manager (NCM) is a management application that 
provides centralized configuration and system management capabilities for a 
multi-BCM network. NCM automates data backups and supports efficient 
distribution of common files. Common configuration tasks can be automated by 
scheduling optimized work flows. With NCM, bulk distribution of BCM software 
patches becomes a simple, efficient, and automated process.

This release of NCM for BCM3.7 enables you to update your existing NCM3.6 
installation to add support for BCM3.7 systems, in addition to those BCM systems 
already supported by NCM3.6. 

This chapter provides the following information:

• “New features”

• “Supported platforms”

• “Known anomalies in NCM for BCM3.7 cartridge” on page 14

• “NCM3.6 CRs corrected on NCM for BCM3.7 cartridge” on page 14

• “Known anomalies in NCM3.6” on page 15

New features

The NCM for BCM3.7 software has added the ability to perform configuration 
management on BCM3.7 devices. 

Supported platforms 

The NCM for BCM3.7 cartridge is installed on the NCM3.6 server; therefore 
BCM3.7 cartridge runs on the same platforms as the NCM3.6 server. See the 
Network Configuration Manager 3.6 Installation Guide for a list of the supported 
platforms.
Release Notes and Cartridge Installation Guide for BCM3.7
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Known anomalies in NCM for BCM3.7 cartridge

Web Cache enhancement

NCM does not support the Web Cache security enhancement implemented in 
BCM3.7. The Web Cache enhancement must be configured through the Unified 
Manager on the BCM.

Call Detail Recording settings

NCM does not support the Include Matrix File field under the Data File Transfer 
tab implemented in BCM3.7. This field must be configured through the Unified 
Manager on the BCM. Exports of the existing supported parameters are not 
affected by this unsupported field.

NCM3.6 CRs corrected on NCM for BCM3.7 cartridge

This section lists the CRs corrected by the NCM for BCM3.7 cartridge. The 
functionality of the listed CRs is corrected on any NCM3.6 with the NCM for 
BCM3.7 cartridge installed.

Password change wizard

When the export checkbox in the Password Change wizard is selected, the 
password is changed on the physical device. However, the device representation 
in NCM still contains the old password within its connection parameters. (CR 
Q00531581)

This CR has been corrected. NCM now contains the updated password.
N0033985 1.0
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Executing Trim Archive wizard on File Management folder

The Trim Archive wizard, available under the File Management folder, trims the 
number of archives folders for each device on which the wizard is run. The Trim 
Archive wizard runs correctly when used on only one device. However, if used on 
multiple devices, as when a folder is selected, the wizard incorrectly deletes 
archives from the devices contained in the folder, and you lose more archived data 
than originally specified.

To ensure that data is not lost, only run the Trim Archive wizard on one device at 
a time.

This CR is now corrected. You can run the Trim Archive wizard on multiple 
devices at the same time.

Known anomalies in NCM3.6

See Appendix A on page 21 for a complete list of all of the known anomalies in 
NCM3.6.
Release Notes and Cartridge Installation Guide for BCM3.7
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Chapter 2
Installing NCM for BCM3.7

This chapter includes installation procedures for both Windows and Solaris environments. 
The following two points must be implemented, regardless of the operating system, in 
order for the installation of NCM for BCM3.7 cartridge to be successful.

• NCM3.6 must be installed before attempting to install the NCM for BCM3.7 
cartridge. 

• The NCM for BCM3.7 must be installed in the same directory as NCM3.6 installation 
directory.

Installing NCM for BCM3.7 in a Windows environment

Use the following steps to install the NCM cartridge for BCM3.7:

1 Connect to Unified Manager on your BCM3.7 from your NCM3.6 server.

The BCM Unified Manager opens.

2 Select Install Clients from the BCM Unified Manager.

The Download Client Applications web page appears.

3 Under Administrative Tools, select NCM update for BCM3.7. 

The NCM update for BCM3.7 web page appears.

4 Click the Download NCM update for BCM3.7 - Windows OS link to download the 
NCM update.

The NCM update for BCM3.7 executable, NCM_3.7.exe, is downloaded to your 
computer.

5 Stop the NCM Server or Service, if it is running. 

6 Double-click the downloaded NCM_3.7.exe file to run the install.
Release Notes and Cartridge Installation Guide for BCM3.7



18 Chapter 2 Installing NCM for BCM3.7
7 Follow the instructions in the installer window. When installation is complete, click 
Finish.

8 Start the NCM Server or Service.

9 After installation is confirmed, you can delete the .exe file from your system.

Uninstalling NCM for BCM3.7 in a Windows environment

NCM for BCM3.7 can be removed only by uninstalling and reinstalling the NCM3.6 
product.

Installing NCM for BCM3.7 in a Solaris environment

Use the following steps to install the NCM cartridge for BCM3.7:

1 Connect to Unified Manager on your BCM3.7 from your NCM3.6 server.

The BCM Unified Manager opens.

2 Select Install Clients from the BCM Unified Manager.

The Download Client Applications web page appears.

3 Under Administrative Tools, select NCM update for BCM3.7. 

The NCM update for BCM3.7 web page appears.

4 Click the Download NCM update for BCM3.7 - Solaris OS link to download the 
NCM update.

The NCM update for BCM3.7 executable, NCM_3_7.bin, is downloaded to your 
computer.

5 Stop the NCM Server or Service, if it is running. 

6 Run the ./ncm_3_7.bin file to run the installer.

7 Follow the instructions in the installer window. When installation is complete, click 
Finish.

8 Start the NCM Server or Service.

9 After installation is confirmed, you can delete the .bin file from your system.
N0033985 1.0
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Uninstalling NCM for BCM3.7 in a Solaris environment

NCM for BCM3.7 can be removed only by uninstalling and reinstalling the NCM3.6 
product.
Release Notes and Cartridge Installation Guide for BCM3.7
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Appendix A
NCM3.6 Release Notes

This appendix contains the release notes for NCM3.6 (P01012918 1.1). All of the 
features, information, and anomalies pertaining to NCM3.6 are relevant to NCM 
for BCM3.7, except for the information listed in “NCM3.6 CRs corrected on 
NCM for BCM3.7 cartridge” on page 14.

Introduction

These release notes, which describe the latest enhancements and changes to the 
Network Configuration Manager* (NCM) software, supplement the Network 
Configuration Manager documentation set. Read these notes before you install or 
use the software.

Network Configuration Manager works with Business Communications Manager 
Release 3.6, 3.5, and 3.0. Additional releases of BCM can be supported by 
NCM3.6 through the installation of release-specific cartridges.

New Features

The following are new features that have been included in NCM3.6.

Executing NCM wizards

In NCM3.6, wizards are no longer available by default. Instead, the NCM 
administrator must grant or deny users and groups access to use the NCM wizards. 
For more information, see the Network Configuration Manager Administration 
Guide.

Note: If you migrate from an earlier version of NCM to NCM3.6, the 
NCM administrator still must allow access to the wizards, even though 
access already was granted automatically in a previous version.
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Install as a Service

You can specify the NCM server to run as a Service on Windows operating 
systems during the NCM installation process. The installer also can run as a 
daemon process on UNIX operating systems.

If you run install as a service more than once on the same machine, the first 
installation instance is the server (service) to which the client connects. To call a 
new server, you must run the stop_remove.exe (or .sh), and then install a new 
server (service).

Policy Device Wizard

The Business Communication Manager Policy Device Wizard is added to the 
Services > Policy Management > QoS > Devices path. It allows you to add or 
delete interface groups for Quality of Services management.

Installation notes

This section provides supplemental information about installing Network 
Configuration Manager 3.6 software. For complete information about installation 
requirements and installation tasks, see Installing Network Configuration 
Manager.

Client Install

In order to install the NCM client software on any of the Windows platforms, you 
must be a registered, authenticated user. If you do not have an account on the local 
PC where you are attempting to install the client, NCM goes through the 
installation process, but the NCM directory remains empty.

Web server migration

After migrating data from a previous version of NCM to NCM3.6, you must 
update the Server Setup > Web Server properties to point to the new NCM 
installation directory. If you do not, the older version of the NCM Client starts.
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Known anomalies in NCM3.6

Archiving files larger than 32 MBytes in size

When trying to archive a patch or image larger than 32 Mbytes in size, using 
NCM, the operation can stay at 0%, and fail with error TFTP block number 
65536 had to be resent showing on the NCM server log. TFTP operations 
support file sizes up to 32Mb. 

FTP must be used for larger files. BCM Cumulative patches, as well as many 
applications/client software patches, can be in excess of 32Mb in size, and must 
be archived using FTP rather than TFTP, as described in the NCM3.6 Client 
Software User Guide.

To send larger files to the BCM network, you also can increase the BCM timeout 
period value to avoid timeout errors. This property can be set on the NCM 
Properties dialog box for each device.

Running NCM as a Windows service. 

If NCM is running as a Windows service, the NCM administrator cannot access 
the NCM server console window, because services in operating systems cannot 
have a user interface. This is an intended limitation.

NCM Keycode not found issue

In some circumstances, the NCM server reports the following error, NCM 
Keycode not found, when trying to perform an import operation from the 
network, although the NCM keycode actually is installed on the BCM. If you 
encounter this situation, contact Nortel Support for instructions on how to resolve 
this issue. 
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Connectivity broken issue 

In some circumstances, the NCM server is unable to import a configuration from a 
BCM, and the NCM server reports the following error, Connectivity between 
NCM application & BCM device may have been broken during the 
operation. Once you have verified that there is no network connectivity issue, and 
that both NCM and BCM have been correctly set up to support NCM import 
operations, contact Nortel Support for instructions on how to resolve this issue. 

Inventory Reporting

The following three issues can affect the number of MBMs and ports included in 
the inventory reporting:

• An inventory utility is run at nightly 3:00 a.m. on NCM-managed BCMs. 
Therefore, if new media bay modules (MBM) are added to an BCM, and 
an NCM re-import is performed that same day, the new MBMs are not 
visible yet to NCM.

• DSM MBMs must have at least one active set attached to them in order to 
be recognized and counted in the BCM inventory reports. This can cause 
discrepancies between the number of physical MBMs and ports 
physically installed and available on the BCM, and the MBMs and ports 
reported by NCM. 

• The BCM inventory is unable to differentiate between DSM16, DSM32, 
and DSM32+ MBMs. This causes the MBMs to be misrepresented in the 
Media Bay Modules report. 

Erroneous error message when exporting password 
changes for dialup, PPTP, and IPSec users

NCM generates an erroneous error message when exporting password changes for 
dialup, PPTP, and IPSec users. A dialog box appears at the end of the operation 
with the generic error, user name is in use by an IPsec Remote User. User 
cannot be deleted, when trying to change a user password. Ignore this error 
message, as the user password changes are exported successfully to the BCM. 
(CR Q00995001)
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Erroneous error message when exporting changes to 
callback settings

NCM will display an error message in a dialog box at the end of an export of 
either an enable or disable of Callback settings to BCM. Ignore the error message, 
as the changes are reflected in the BCM after the export. (CR Q00995003)

IPSec Branch Office Tunnel support

NCM Branch Office Tunnel wizard, visible only in NCM node Services > VPN > 
IPSec > Branch Office Accounts, is not supported. This wizard does not 
configure correctly branch office IPSec tunnels on BCMs. 

IPSec branch office tunnels must be created and enabled through the Unified 
Manager on the BCM. 

NCM can import existing IPSec branch office tunnels, and can be used to modify 
and export IPSec branch office tunnels that had previously been imported from a 
BCM. (CR Q00998229) (CR Q00998224)

IPSec Remote User Account support

NCM BCM IPSec Remote User Account Wizard, visible only in the NCM node 
Services > VPN > IPSec > Remote User Accounts, is not supported. This wizard 
does not configure correctly remote user accounts. 

IPSec remote user accounts must be created through Unified Manager on the 
BCM. 

NCM can import existing IPSec remote user accounts, and are used to modify and 
export IPSec remote user accounts previously imported from a BCM. (CR 
Q00998231)

PPTP tunnel wizard support

NCM BCM PPTP Tunnel Wizard, visible only in the NCM node Services > VPN 
> PPTP, is not supported. This wizard does not configure correctly PPTP 
tunnels.
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PPTP tunnels must be created using Unified Manager on the BCM.

NCM can import existing PPTP tunnels, and are used to modify and export PPTP 
tunnels previously imported from a BCM. (CR Q00998234)

Intermittent call routing error messages

The Call Routing Wizard displays the error message, This node is no longer 
valid, after call routing configuration has completed, if the BCM core telephony 
feature is busy at the same time as the configuration change is attempted. You 
must re-apply the export at a later time. (CR Q00999256)

Keep-Alive-enabled field not present for IPSec Branch 
Office Account and Remote User Account

NCM does not support the Keep-Alive Enabled field for the IPSec Branch Office 
Account and the Remote User Account. This option must be configured through 
the Unified Manager on the BCM. 

Executing Trim Archive wizard on File Management folder

The Trim Archive wizard, available under the File Management folder, trims the 
number of archived folders for each device on which it is run. The Trim Archive 
wizard runs correctly when used on only one device. However, if used on 
multiple devices, as when a folder is selected, the wizard incorrectly deletes 
archives from the devices contained in the folder, and you lose more archived data 
than originally specified.

To ensure that data is not lost, only run the Trim Archive wizard on one device at 
a time.

The NCM 3.6.0.1 patch corrects this issue and allows for the Trim Archive wizard 
to be run on multiple devices at one time.
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NCM does not support SRG 1.0

Using NCM3.6 to apply the SRG 1.0 key code is not supported. If you choose to 
apply the SRG 1.0 key code to your BCM devices using NCM3.6, you will 
adversely affect your network.

Export when voicemail is not initialized

You can export voicemail changes to an uninitialized CallPilot (prior to running 
the CallPilot wizard). However, such voicemail programming is activated upon 
the initialization of CallPilot. (CR Q00677039)

NCM NetIQ IP address value

The * value is a valid input for NetIQ Authorized Management Servers in Unified 
Manager. However, when you enter * as a value in NCM > Services > Net IQ IP, 
and then export the configuration to a BCM device, the IP address field is left 
blank. To properly export the field, enter a range of IP addresses in NCM3.6, or 
configure the field in Unified Manager. (CR Q00842257)

Extra holiday folders

When you create a number of holiday folders under NCM > Voice Mail > Auto 
Attendant > Holidays, without changing the defaults on each new holiday entry, 
the newly configured holidays are not exported until the extraneous holiday 
entries (those that are configured from the default) are deleted. (CR Q00837178)

H.323 trunks gatekeeper values blank

After importing a device to NCM, the H.323 Trunks Primary Gatekeeper IP, 
Backup Gatekeeper IP, and Alias Names fields are all blank in NCM. Unified 
Manager displays the default values for each field that is not set, but this behavior 
does not translate to NCM. (CR Q00823461)
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Config archive file naming

You must tab out of the Name field of the Config Archive dialog box before 
clicking the Send button to ensure the name is retained; otherwise, if you do not, 
the file automatically is named BCM. (CR Q00757238)

NCM reports do not check user permissions

When you generate a report in NCM, data that you do not have permission to 
“read” can be included in the report. The report generator does not check user 
permissions before outputting the report. (CR Q00806529)

Reboot after applying keycodes

When applying keycodes through NCM that require a reboot to take effect, NCM 
does not prompt for a reboot, in some cases. After applying a keycode in NCM, 
you must reboot your system for the changes to take effect.

Exporting policy to BCM fails

When you create a policy in NCM, and then export it to a BCM device, the export 
operation fails, and the policy is not exported to the device. You must add all new 
policies directly to the BCM device through Unified Manager. (CR Q00862240)

ISDN field blank after import

When you create an ISDN entry on a BCM device, and then import the device to 
NCM, the import operation is successful, but the ISDN version field is blank. The 
value of the field is not imported properly. (CR Q00865090)

DLCI to IP mapping entries not imported

When you add a DLCI to IP Mapping tab entry on a BCM device, and then import 
the device to NCM, the import operation is successful, but the DLCI to IP 
Mapping entry is not imported properly. The DLCI and IP Address fields are 
blank. 
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Also, the IP Mapping tab does not display the Local IP and Remote IP Address 
fields. These fields must be displayed under the IP Mapping tab. Due to the 
absence of these field values, you will receive an export error after changing 
DLCI to IP Mapping entries, and attempting to export them to the BCM device. 
(CR Q00868006 and Q00868013)

Incorrect Call Pilot version in IVR report

When you run the Report Generator Wizard in NCM, and select “Voicemail” 
IVR, the report window displays an incorrect version of the Call Pilot Manager 
BCM Voicemail. Instead of displaying the current version, the report window 
displays Call Pilot Manager BCM Voicemail version 1.0. (CR Q00841461)

Known problems in previous versions of NCM

Timeout errors when importing device configurations 

When you import a BCM configuration for the first time, increase the timeout to 
at least 600 (the default is 60) in the Import from Network dialog box. 
Increasing the timeout prevents the driver from timing out when the inventory 
process takes longer than the original timeout value.

When you import and export configurations to and from devices on the network, 
NCM waits for a response from the device. If the timeout period, which is 
device-dependent, expires, and NCM has not received a response from the device, 
NCM displays a timeout error message. 

To increase or decrease the timeout period for a device, open its Properties dialog 
box, and click the Import or Export tab. Change the timeout period, and click 
OK.

In some situations (for example, over a busy WAN connection), the default 
timeout period is not long enough to receive a response from a device. In these 
situations, you can increase the timeout variable. You can set the timeout variable 
for devices on the Import tab and the Export tab for each device. 
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IVR service start

When using IVR, the IVR service is not started automatically after a restore 
operation. IVR service can be started from Unified Manager > Diagnostics > 
Service Manager. Search for Nortel Networks Startup Service, change the 
Startup to Automatic, and change Status to Started. The IVR then is functional. 
(CR Q00504754)

Progress bar

If you choose more than one configuration in the Configuration Data sub-tree, and 
import or export the configurations to the network, the progress bar behaves 
erratically, and is inconsistent with the actual progress of the operation. (CR 
Q00681693)

NCM potentially unreachable with dual NIC

If the NCM server machine has multiple IP addresses, it is advisable to include the 
command line argument -host <ip_address of NCM server>, and inform all NCM 
clients of the IP address. 

Archive label not migrated from Oracle database

When you migrate archived entries, the label and comments are not migrated with 
the entries. Instead, a timestamp appears in place of the label, and any comments 
are gone. (CR Q00715339)

Patch distribution

You must specify a longer timeout interval when running a Send Image to 
Network operation. 
N0033985 1.0



31
Drop-down list not available

In NCM 3.0, under IP Firewall Filters > LAN/WAN/UTWAN > Destination 
Port Range, a drop-down menu is not available because it is located in Unified 
Manager. You must type in the label of the port, port number, or port range. (CR 
Q00671770)

Naming conventions do not match Unified Manager

Naming conventions for dial-up items, such as Modem and ISDN interfaces in the 
Resources node, do not match the names found in Unified Manager. In NCM, the 
convention is Interface ID <interface or user name>.

Password change wizard

When the export checkbox in the Password Change wizard is selected, the 
password is changed on the physical device. However, the device representation 
in NCM still contains the old password within its connection parameters. (CR 
Q00531581)

Log rotators after migration

Log rotator settings are not migrated from NCM 2.0 to NCM 3.0. Instead, default 
log rotator settings are created when the NCM 3.0 database is created originally.

Server messages incorrectly formatted in File > Send

When selecting multiple Common Files to send to the network, the operation’s 
server log message combines all the file names into one string, and the message is 
formatted as though the multiple files are a single file. (CR Q00741834)

Wrong filename shown after using Browse function

When sending Common Files to the network, you have the option of using 
Browse to select Configuration Data devices. However, when you use the Browse 
function, the progress label displays “sending file to null.” (CR Q00732291)
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Wrong filename shown in FTP Send

When performing a File > Send to FTP operation, you can change the filename 
by double-clicking it. However, the progress label does not register the change 
and instead reports “sending <old filename>.” (CR Q00732289)

Starting syslog with the web server

When you start the server, if the web server cannot start on its port, the web server 
fails and does not set a “docroot” value for the path to the install directory. The 
syslog server needs this value to locate the appropriate syslog.txt file. Once the 
webserver starts successfully at least once, the docroot is defined, and the syslog 
server can start with or without the web server.

Increasing the limit of concurrent user sessions

To avoid overloading, NCM has a default limit of ten concurrent server operations 
at any time, with a maximum of five operations per client request. If you wish to 
change the number, you can do so in the datastore.ini file in the installation 
directory. The semaphores can be modified by changing the “maxConnections=” 
line in the datastore.ini file on the server. Semaphore count can be up to 40 for a 
high-powered server machine.

Truncated menus

If you rely on the right-click method for running operations, you cannot view all 
menu options. The calculation for screen placement of the dialog box uses only 
the size of the main menu, without incorporating the size of any cascading 
submenus. It is possible, in some cases, to have a submenu truncated. In these 
cases, use the menu bar to perform the operations, or move the NCM client 
window to enable the submenus to display fully.
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Audit log inconsistencies

Tools > Audit Log > on selected item does not display an audit log for these 
object types:

• device > subnodes

• Schedule folder > Log rotator objects

Audit log entries are not recorded for these operations:

• Operations on a device as a result of running a wizard

• Archive of common files

• File > Send to Network (CR Q00741839)

Telnet session history list

The Telnet session panel history list remains empty regardless of how many 
device sessions you open.

Send to TFTP using a remote server

When you Send to TFTP using a remote server across a WAN, a timeout message 
can appear, even though the operation was successful. To prevent the timeout 
message from displaying, ensure that all Send to TFTP operations use a remote 
server on the LAN. You also can place the files you want to send on your TFTP 
server, and then perform an Archive From TFTP from the remote server, rather 
than sending from a local server.

Using the Netscape browser on Solaris

NCM can have a problem automatically starting Netscape when using Web Links 
or the Report Wizard. If this occurs, start a browser session separately, and NCM 
then displays links using the existing browser window.
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Log rotators

The log rotators sometimes can stop archiving log files after changes are made to 
the rotation schedule. If this occurs, uncheck and recheck the “Rotate Log Files by 
Date” checkbox under Server Setup > Log Setup > <log_file>. This resets the 
log rotator. 

Operation progress bar

During several operations, such as Import from Network and Send to Network, 
the progress bar remains at a percentage for a long time. This is normal, and can 
last for several minutes.

Import data

Telephony changes to lines and sets are not reflected in import data until the next 
day. Changes made to the Business Communications Manager are not reflected in 
the import data immediately. You must schedule an import to take place after 
3:00 a.m. (the time that the line and set inventory takes place) in order to update 
NCM.

Viewing syslog messages

When you change the IP address for remote logging or change from remote to 
local logging, you cannot view syslog messages. You must disable, and then 
reenable, the syslog server to view syslog messages properly.

TFTP server on Solaris platforms

The NCM server does not recognize alternate IP addresses assigned to interfaces 
on machines running Solaris 8. As a result, NCM does not populate the list for the 
internal TFTP server. 
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Operational notes

This section provides operational notes for the Network Configuration Manager 
3.6 release.

General issues and recommendations

• NCM supports multiple login sessions for a particular user ID. You can use 
this feature so that first-level support engineers can log in with one user ID, 
second-level support engineers can log in with another user ID, and so on. 
Note, however, that the audit log records information is based on user ID. 
Therefore, in this scenario, you determine only the level of the engineer who 
performed a particular task; you can not determine the identity of the 
particular engineer who performed a particular task. 

• If you change the settings on the system clock, you must restart the NCM 
server and client software; otherwise, NCM continues to operate based on the 
old system clock settings. 
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